Major Public Network Outage
Incident Report for Stellar.org
Postmortem

Post Mortem can be found at Stellar Developers blog: https://medium.com/stellar-developers-blog/may-15th-network-halt-a7b933103984

Posted 4 months ago. May 20, 2019 - 10:23 UTC

Resolved
Posted 4 months ago. May 15, 2019 - 21:21 UTC
Investigating
Investigating Stellar Public Network issues.
Posted 4 months ago. May 15, 2019 - 20:14 UTC
This incident affected: Stellar Public Network.