Testnet performance degraded
Incident Report for Stellar.org
Resolved
We confirmed that the fix addressed the problem and the service is now stable.
Posted Mar 14, 2024 - 13:16 UTC
Monitoring
We deployed a fix and service recovered. We are monitoring the service
Posted Mar 14, 2024 - 10:15 UTC
Identified
We identified likely root cause and are working on a fix.
Posted Mar 14, 2024 - 09:12 UTC
Investigating
SDF testnet horizon ingestion has stopped. Historical data is still available.
Posted Mar 14, 2024 - 07:02 UTC
This incident affected: Stellar Test Network and SDF Test Network Horizon.